Passer au contenu du forum

L'Agora sur Chronica

Savoir c'est pouvoir, le libre savoir c'est la liberté.


Écrire une réponse

L'Agora sur Chronica » Les mods » I have a dream » Écrire une réponse

Écrire une réponse

Composez et envoyez votre nouvelle réponse

Vous pouvez utiliser : BBCode Images Binettes

Tous le champs doivent être remplis avant d’envoyer ce formulaire, ou alors vous avez utilisé la fonction copier/coller qui n'est pas supporté par l'éditeur de texte.

Information obligatoire pour les invités


Information obligatoire

Revue du sujet (plus récents en tête)

31

D'accord Michel,

je viens de faire un copier-coller de mon post antérieur dans la section des Bogues de ce site.

André

30

Ange,
a priori, non...
pour en être certain, va dans l'onglet "Analyse fichiers TNG" et dans la liste proposée tu cherches après  templates/template16/index.php. Tu cliques dessus et à droite tu vois apparaitre les Mods qui modifient ce fichier.
Probablement que ton fichier templates/template16/index.php es corrompu ou a été modifié.
Remplace  le par une copie fraiche provenant de tes fichiers originauxde TNG.

S'il te plait, ouvre un nouveau post pour un nouveau problème !
par exemple, pour celui-ci, tu vas dans accueil>>sélectionne la rubrique "bogues..." et cliques en haut à droite sur "Créer un nouveau sujet". Donne lui un titre explicite (pas "problème" ou "j'ai besoin d'aide", mais "Installation Mod Hide menus Ne peut pas installer", ça c'est bon...
Ca aidera déjà pas mal pour retrouver des infos dans le forum... Merci

29

Merci Michel pour ce mod qui sera très apprécié de plusieurs, j'en suis sûr.

J'ai essayé d'installer le mod beta de ton post antérieur et ça me donne le message "Ne peut pas installer". J'ai bien pris soin auparavant de supprimer l'ancien mode "Hide_google_buttons".

Le seul message d'erreur que j'ai dans la liste de vérification d'installation est celui-ci :

ligne 673: %target:@templates/template16/index.php% vérifié
ligne 675: %location:% #1 Mauvaise cible

J'utilise le template 13.

Voici les mods que j'utilise. Est-ce qu'il y en aurait un là-dedans qui serait incompatible?


https://agora.chauvigne.info/uploads/images/2021/03/22/image.png

28

Bonjour Katherine et Michel
Nouveau dans cette Agora que je trouve extra ordinaire  mais j'ai dû mal à trouver le message susceptible de m'intéresser.
Alors voici ma propal :
Ne peut-on pas liste les messages de réponse dans l'ordre descendant? Le réponses les plus récentes étant en haut alors.
Cordialement
Ange

27

Voici la version actuelle du Mod.
S'il cache bien les menus demandés, partout et dans tous les templates,
vous remarquerez qu'il laisse des trous dans les pages d'accueil.

Est-ce gênant ou pas? A vous de me le dire...

Je suis prêt à modifier le Mod en fonction du template que vous utilisez afin qu'il n'y ait pas ces trous
dans les pages d'accueil. Mais je ne suis pas prêt à modifier pour les 18 templates en une seule fois, peut-être pour rien.

Donc, essayez et dites-moi ...

Ce Mod remplace le Mod Show_Hide_Menus et est incompatible avec Hide Google Search. Il les remplace tous les deux!

Michel

hide_menus_v13.0.1.beta1.zip  13.6   (78)

26

J'ai vu que Philippe avait utilisé par contournement le champ titre pour rappeler les professions de ses ancêtres. C'est une bonne idée mais le champ ne s'y prête pas trop.
Ne vaudrait-il pas mieux demander la création d'un nouveau champ dédié à Darrin pour  la prochaine mise à jour?
Ange

25

Extraordinaire... Bof!Bof!
Je n'en suis pas très content et j'avais laissé tomber depuis quelques temps.
Notamment parce qu'il remplace des pans entiers de code TNG et que c'est quelque chose que je déteste quand ce sont les autres qui le font.
Voici la version actuelle, à laquelle il faut encore intégrer le "Hide Google Search button" et le code pour chaque template.
Bref on n'a pas réellement avancé...
Et vu tout ce que j'ai sur le feu actuellement (Pffft ! je n'en sors pas...)

show_hide_menus_v13.0.1.beta2.zip  12.1   (70)

Michel

24

Ce mod "Shwo Hide Menu" semble vraiment extraordinaire. Je cherchais quelque chose de semblable depuis longtemps. J,ai vu la page de test de Katryne et ça semble très prometteur.

Est-ce que ce mod est disponible ou est-ce encore à l'étape expérimentale?

Merci,

André

23

Oui, effectivement, ce texte... n'existe pas dans TNG. Dingue, non?
Je l'avais "inventé" pour l'admin de Sosa.
Je l'ai mis dans la nouvelle version du Mod.

Inscrire ceci dans cust_text.php, à la suite des autres :

// Show hide Menus Mod
$admtxt['restore'] = "Restaurer les valeurs par défaut";
// Show hide Menus Mod

Michel

22

J'ai corrigé comme tu m'as dit pour le mod de Brett.
J'en ai profité pour remplacer tous mes fichiers de langue Française (sauf cust machin) par ceux du pack 13.0.1, mais j'ai toujours pas de texte pour le bouton restore.

21

Katryne a écrit:

Pour mon site qu'a un comportement bizarre, je pensais à un mod qui aurait été mal désinstallé. Voilà ce que je viens de poster sur le forum TNG : https://tng.community/index.php?/forums … ment-77156

Et c'est assez logique d'intégrer le binz de la recherche Google dans ce nouveau mod.

Vois dans le fichier cfg de ce Mod ce qui est sensé être installé (fichier, location)
et regarde dans le fichier sensé être modifié si le Mod est vraiment effacé...

Michel

20

Les liens dans la page d'accueil ne sont pas cachés.
C'est pourquoi je disais ... "pas encore complet"..
Les liens de la page d'accueil font partie du template.
Et je dois donc écrire le code (4 lignes par menu à cacher) pour
les 20 templates... Pffft !

Michel

19

En fait, ça marche pas avec mon thème. J'ai toujours en accueil  les liens cimetières, calendrier etc qui sont pourtant configurés comme non affichés dans le mod.

18

Katryne a écrit:

Salut Michel !

3/ Je le configure avec easy edit et il fait son job
4/  Une fois que j'ai configuré dans easyEdit, je reste coincée sur une page quasi vierge, sans possibilité d'en sortir. Je dois alors fermer l'onglet et en ouvrir un autre pour ouvrir de nouveau le site. Easy Edit devrait s'ouvrir en _blank au lieu de _self pour éviter ce souci
Sur la page quasi-vierge  https://tng-test.revestou.fr/show_hide_menus_admin.php# où je suis, j'ai juste le lien vers l'aide du mod et un texte affiché :

Bizarre.
Ce qui pose problème, c'est ce '#' en fin d'adresse...
Si tu l'effaces la page Easy Edit revient normalement.
Je ne peux pas l'ouvrir en _blank car si on la ferme avec le bouton, on revient... je ne sais où et le risque c'est que la page Easy Edit puisse être ouverte plusieurs fois...

17

Pour mon site qu'a un comportement bizarre, je pensais à un mod qui aurait été mal désinstallé. Voilà ce que je viens de poster sur le forum TNG : https://tng.community/index.php?/forums … ment-77156

Et c'est assez logique d'intégrer le binz de la recherche Google dans ce nouveau mod.

L'Agora sur Chronica » Les mods » I have a dream » Écrire une réponse



PunBB.INFO - расширения и темы на заказ