1 03-11-2020 23:15 -

Bonsoir à tous,
En effet je rêve mais.......
Pourrions nous imaginer un mod qui masque (à la demande par choix) les onglets que nous n'utilisons pas dans les menus Médias, Chercher et Info?
Merci,

Philippe
---------------------
www.meresse.be

2 04-11-2020 13:24 -

Je me demande si cela n'existe pas déjà.
A cacher côté utilisateurs, je suppose?

A priori, pas très difficile...
Quelqu'un d'autre est intéressé?
Michel

3 04-11-2020 13:52 -

Bonjour Michel,
En effet, c'est bien pour alléger les menus déroulants pour l'utilisateur afin de ne cibler que ce qui est utilisé ou avec du contenu.
Merci,
Philippe

4 07-11-2020 10:28 -

Bonjour tous,

Je masque également des items du menu .menulink via genlib.php. Il n'existe pas encore de Mod qui fait cela
Jean-Louis

5 09-11-2020 01:30 -

Eh bien vous serez servis !
Si vous voulez bien tester ce Mod...
Attention : tous les menus (y compris les menus personnels)
ne sont accessibles que par le bouton "Edition facile" dans le Mod Manager.

https://agora.chauvigne.info/uploads/images/2020/11/08/easy_edit_button.jpg

show_hide_menus_v13.0.1.1.zip  11.6 Ko  (110)

6 09-11-2020 02:17 -

Le Mod est installé. C'est parfait, je n'ai désormais plus besoin de corriger genlib.
Merci Michel
JLouis

7 09-11-2020 10:04 -

Bonjour,
Avant d'installer ce nouveau mod, je pense avoir besoin d'aide, en effet depuis quelques jours j'ai ce message et plus aucun accès à mon site, que faire:

Warning: mysqli_set_charset(): Error executing query in /htdocs/tngconnect.php on line 103
Une erreur est intervenue dans le logiciel TNG. Ce que vous devez faire :
Si vous venez d'installer une mise à jour, vous avez peut-être sauté une partie des instructions d'installation. Retournez à la page du Lisez-moi pour relire les instructions. Prêtez une attention particulière à l'étape de la structure de la base de données.

Si vous venez de faire une première installation de TNG, il est peut-être encore nécessaire de créer les tables de la base de données. Revenez à la page du lisez-moi pour retrouver cette étape.

Si vous êtes le propriétaire du site, vous pouvez contacter le service assistance de TNG pour obtenir une aide supplémentaire sur ce problème. Merci de copier la requête ci-après et collez-la dans votre message.



Requête: SELECT * FROM tng_mediatypes ORDER BY ordernum, display

User 'meres1284938' has exceeded the 'max_queries_per_hour' resource (current value: 40000)

8 09-11-2020 11:14 -

Bon ça refonctionne parfois mais...??? j'en profite pour installer le Mod et c'est parfait. C'est exactement ce que je souhaitais.
Grand merci Michel.
Dans un autre ordre d'idée, serait-il possible de remplacer l'onglet "Medias" par autre chose ? exemple: "Informations"?
Merci,
Philippe

9 09-11-2020 12:06 - Dernière modification par MichelKirsch (09-11-2020 12:08)

philippe a écrit:

User 'meres1284938' has exceeded the 'max_queries_per_hour' resource (current value: 40000)

La réponse est dans la question : pas plus de 40.000 queries par heure ! Dis donc. Il y a du trafic sur ton site...
Michel

10 09-11-2020 12:07 -

Content que vous soyez contents... mais j'attends la suite...
:-)

Michel

11 09-11-2020 12:37 -

Salut Michel !

1/J'ai un conflit avec un autre mod mais je n'ai pas encore trouvé lequel. Ce conflit empêche le mod de s'installer, comme je t'ai écrit hier soir.
2/ si je désinstalle tous les mods, alors Show Hide menu peut s'installer
3/ Je le configure avec easy edit et il fait son job
4/  Une fois que j'ai configuré dans easyEdit, je reste coincée sur une page quasi vierge, sans possibilité d'en sortir. Je dois alors fermer l'onglet et en ouvrir un autre pour ouvrir de nouveau le site. Easy Edit devrait s'ouvrir en _blank au lieu de _self pour éviter ce souci
Sur la page quasi-vierge  https://tng-test.revestou.fr/show_hide_menus_admin.php# où je suis, j'ai juste le lien vers l'aide du mod et un texte affiché :

mods/eegen_temp_files/show_hide_menus_v13.0.1.1.cfg.old

Je continue les tests pour savoir avec quel mod se dispute Show Hide menu.

12 09-11-2020 12:45 -

Et le coupable est ...
                                                Hide Google Search Buttons

Tu connais l'auteur ?

13 09-11-2020 12:45 - Dernière modification par MichelKirsch (09-11-2020 12:46)

Katryne a écrit:

Salut Michel !

1/J'ai un conflit avec un autre mod mais je n'ai pas encore trouvé lequel. Ce conflit empêche le mod de s'installer, comme je t'ai écrit hier soir.
2/ si je désinstalle tous les mods, alors Show Hide menu peut s'installer
3/ Je le configure avec easy edit et il fait son job
4/  Une fois que j'ai configuré dans easyEdit, je reste coincée sur une page quasi vierge, sans possibilité d'en sortir. Je dois alors fermer l'onglet et en ouvrir un autre pour ouvrir de nouveau le site. Easy Edit devrait s'ouvrir en _blank au lieu de _self pour éviter ce souci
Sur la page quasi-vierge  https://tng-test.revestou.fr/show_hide_menus_admin.php# où je suis, j'ai juste le lien vers l'aide du mod et un texte affiché :

mods/eegen_temp_files/show_hide_menus_v13.0.1.1.cfg.old

Je continue les tests pour savoir avec quel mod se dispute Show Hide menu.

Je vois : le comportement est plutôt erratique sur ton site... Bizarre....
Mais je crois qu'on est en train de travailler à deux. Je te laisse faire...

14 09-11-2020 12:52 -

Katryne a écrit:

Et le coupable est ...
                                                Hide Google Search Buttons

Tu connais l'auteur ?

Aucune idée...

15 09-11-2020 12:53 -

Je te laisse la main, je touche plus à rien.

16 09-11-2020 12:54 -

Katryne a écrit:

Et le coupable est ...
                                                Hide Google Search Buttons

Tu connais l'auteur ?

Plus sérieusement, je vais reprendre les fonctionnalités de Hide Google Search dans le nouveau Mod...

17 09-11-2020 13:00 -

Pour mon site qu'a un comportement bizarre, je pensais à un mod qui aurait été mal désinstallé. Voilà ce que je viens de poster sur le forum TNG : https://tng.community/index.php?/forums … ment-77156

Et c'est assez logique d'intégrer le binz de la recherche Google dans ce nouveau mod.

18 09-11-2020 13:09 -

Katryne a écrit:

Salut Michel !

3/ Je le configure avec easy edit et il fait son job
4/  Une fois que j'ai configuré dans easyEdit, je reste coincée sur une page quasi vierge, sans possibilité d'en sortir. Je dois alors fermer l'onglet et en ouvrir un autre pour ouvrir de nouveau le site. Easy Edit devrait s'ouvrir en _blank au lieu de _self pour éviter ce souci
Sur la page quasi-vierge  https://tng-test.revestou.fr/show_hide_menus_admin.php# où je suis, j'ai juste le lien vers l'aide du mod et un texte affiché :

Bizarre.
Ce qui pose problème, c'est ce '#' en fin d'adresse...
Si tu l'effaces la page Easy Edit revient normalement.
Je ne peux pas l'ouvrir en _blank car si on la ferme avec le bouton, on revient... je ne sais où et le risque c'est que la page Easy Edit puisse être ouverte plusieurs fois...

19 09-11-2020 13:20 -

En fait, ça marche pas avec mon thème. J'ai toujours en accueil  les liens cimetières, calendrier etc qui sont pourtant configurés comme non affichés dans le mod.

20 10-11-2020 11:50 -

Les liens dans la page d'accueil ne sont pas cachés.
C'est pourquoi je disais ... "pas encore complet"..
Les liens de la page d'accueil font partie du template.
Et je dois donc écrire le code (4 lignes par menu à cacher) pour
les 20 templates... Pffft !

Michel

21 10-11-2020 11:53 -

Katryne a écrit:

Pour mon site qu'a un comportement bizarre, je pensais à un mod qui aurait été mal désinstallé. Voilà ce que je viens de poster sur le forum TNG : https://tng.community/index.php?/forums … ment-77156

Et c'est assez logique d'intégrer le binz de la recherche Google dans ce nouveau mod.

Vois dans le fichier cfg de ce Mod ce qui est sensé être installé (fichier, location)
et regarde dans le fichier sensé être modifié si le Mod est vraiment effacé...

Michel

22 10-11-2020 12:55 -

J'ai corrigé comme tu m'as dit pour le mod de Brett.
J'en ai profité pour remplacer tous mes fichiers de langue Française (sauf cust machin) par ceux du pack 13.0.1, mais j'ai toujours pas de texte pour le bouton restore.

23 12-11-2020 01:34 -

Oui, effectivement, ce texte... n'existe pas dans TNG. Dingue, non?
Je l'avais "inventé" pour l'admin de Sosa.
Je l'ai mis dans la nouvelle version du Mod.

Inscrire ceci dans cust_text.php, à la suite des autres :

// Show hide Menus Mod
$admtxt['restore'] = "Restaurer les valeurs par défaut";
// Show hide Menus Mod

Michel

24 18-02-2021 07:24 -

Ce mod "Shwo Hide Menu" semble vraiment extraordinaire. Je cherchais quelque chose de semblable depuis longtemps. J,ai vu la page de test de Katryne et ça semble très prometteur.

Est-ce que ce mod est disponible ou est-ce encore à l'étape expérimentale?

Merci,

André

25 20-02-2021 12:58 -

Extraordinaire... Bof!Bof!
Je n'en suis pas très content et j'avais laissé tomber depuis quelques temps.
Notamment parce qu'il remplace des pans entiers de code TNG et que c'est quelque chose que je déteste quand ce sont les autres qui le font.
Voici la version actuelle, à laquelle il faut encore intégrer le "Hide Google Search button" et le code pour chaque template.
Bref on n'a pas réellement avancé...
Et vu tout ce que j'ai sur le feu actuellement (Pffft ! je n'en sors pas...)

show_hide_menus_v13.0.1.beta2.zip  12.1 Ko  (66)

Michel