1 22-01-2021 16:40 -

Bonjour Michel,

Apparemment, le Mod ne prend pas en charge l'apostrophe. >>>


Pierre L'HOMME
M vers 1706 - 1794  (~ 88 ans)   0 ancêtres mais plus de 100 descendants dans cet arbre.

Une erreur est intervenue dans le logiciel TNG. Ce que vous devez faire :

Si vous venez d'installer une mise à jour, vous avez peut-être sauté une partie des instructions d'installation. Retournez à la page du Lisez-moi pour relire les instructions. Prêtez une attention particulière à l'étape de la structure de la base de données.

Si vous venez de faire une première installation de TNG, il est peut-être encore nécessaire de créer les tables de la base de données. Revenez à la page du lisez-moi pour retrouver cette étape.

Si vous êtes le propriétaire du site, vous pouvez contacter le service assistance de TNG pour obtenir une aide supplémentaire sur ce problème. Merci de copier la requête ci-après et collez-la dans votre message.


Requête: SELECT assocname from tng_people WHERE lastname = 'L'HOMME'

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'HOMME'' at line 1

WWW

2 22-01-2021 23:02 -

En principe, la version v12.3.0.1a du 10 août 2020 fixait cette erreur.

Quelle version utilises-tu? (OK j'ai vu : la 12.3.0.2 )

Je vais indaguer...

Michel

WWW

3 22-01-2021 23:18 -

Je peux reproduire chez moi.
Je te tiens au courant...
Michel

WWW

4 23-01-2021 00:32 -

Tu es le plus rapide

WWW

5 24-01-2021 17:48 -

Voilà m'sieur.
Je ferai la promotion plus tard...
Michel

associate_names_v12.3.0.2b.zip  10.2 Ko  (206)

WWW

6 24-01-2021 18:41 -

version 2b installée, même message
Requête: SELECT DISTINCT lastname FROM tng_people WHERE assocname = 'L'HOMME' ORDER BY lastname

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'HOMME' ORDER BY lastname' at line 1

ne trouve pas même les noms sans apostrophe

WWW

7 25-01-2021 09:56 -

Il s'agit d'une troisième erreur, différente des précédentes.

Voilà le fix :
Attention, le numéro de version n'a pas changé !

Michel

associate_names_v12.3.0.2b.zip  10.3 Ko  (208)

WWW

8 25-01-2021 11:35 -

Cette fois, pas d'erreur avec l'apostrophe, mais les associations ne sont pas identifiées

WWW

9 25-01-2021 13:37 -

CORRECTION >>>
J'ai parlé trop vite, c'est maintenant opérationnel
Merci Michel

WWW

10 18-02-2021 05:34 -

J'utilise maintenant le module "Associate Names" et j'en suis vraiment satisfait.

Il me semble avoir lu quelque part une explication de Michel sur la façon de créer des Noms 'bidon' lorsqu'aucune fiche de la bd ne contient ce nom. Par exemple, mon site qui comprend maintenant plus de 60 000 religieux et religieuse de l'Amérique du Nord est visité évidemment par des francophones mais il est également consulté beaucoup par des anglophones des États-Unis.

Par convention, les bénévoles du sites, nous avons mis tous les patronymes qui commencent par une voyelle avec accent (ex.: Élie), sans accent pour que les utilisateurs anglophones les trouvent. Cependant, nos utilisateurs francophones ont le réflexe d'écrire ÉLIE avec l'accent aigu et ne les trouve pas. Si je pouvait créer un nom pour la base de donner seulement qui serait écrit ÉLIE, les utilisateurs pourraient alors accéder à tous les Élie, peu importe si ils tapent ÉLIE ou ELIE?

Ou plus cool encore serait que la recherche d'un nom de famille puisse sortir tous les noms peu importe si les voyelles out des accents ou non?

Merci pour votre aide!

11 18-02-2021 21:55 -

a priori, que je cherche ÉLIE, élie, EliÉ, ÉLIÉ, ou elie, mma base me retourne tous
les amélie, Cornélie, Elie, etc...
De même, chercher françois ou francois revient au même.
Tu utilises bien UTF-8 dans ta base et dans TNG?

Je ne vois d'où cela peut venir...

Michel

WWW

12 19-02-2021 07:38 -

Oui, mes deux jeux de caractères pour le français et l'anglais sont UTF-8.

Si je fais une recherche sur le prénom François avec la cédille, j'ai 2,956 résultats dans ma BD. Si je cherche le prénom Francois SANS cédille, j'ai 0 résultat. C'est donc très ennuyeux pour mes utilisateurs francophones. C'est la raison pour laquelle ton mod Associate Names est utile pour moi, non seulement pour d'abord associer des patronymes, mais aussi pour essayer de régler ce problème. J'ai donc mis un accent aigu sur le patronyme Élie d'un individu et je l'ai associé au patronymes ÉLIE, ELIE. Et ça fonctionne! Mais ça risque d'être un peu lourd d'associer tous mes autres patronymes qui commencent avec une voyelle qui a un accent.

Pour ton info : si je fais une recherche sur le nom Élie, ça me sort tous les Hélie mais pas les Elie. Qu'est-ce qui fait que ton TNG te permette de trouver tous les patronymes sans tenir compte des accents?

André

13 19-02-2021 16:48 -

Bonjour Michel,

Voici ce que je vois à propos de ma base de données sur PhpMyAdmin.

J'essaie de te montrer une image en espérant que ça fonctionnera:

https://agora.chauvigne.info/uploads/images/2021/02/19/image.png

André

14 20-02-2021 00:06 -

Je viens de faire une recherche de personnes sur le site test de Katryne et le comportement de la recherche des noms et prénoms avec des voyelles accentués ou le c cédille est le même que sur mon portail. Si je fais une recherche sur le prénom François, seuls les François avec la cédille s'affichent (169 résultats) et si je met Francois dans la recherche, seuls les Franois sans cédille apparaissent (il y en a qu'un seul).

Comment ton site est-il configuré pour avoir les résultats tant attendus... dans mes rêves! :-)

Merci Michel.

15 20-02-2021 00:23 -

Voici ce que je vois à propos de ma base de données sur PhpMyAdmin

J'ai le même interclassement pour le serveur (utf8mb4_unicode_ci).
Par contre mes  tables sont en utf8_general_ci
Ce qui signifie que les données sont triées sans majuscules ou accents, cédilles, chapeaux etc... et donc un à, un a ou un â ou un Â, c'est kif-kif : c'est a


Et toi (vous avec Katryne) ?

Je vas me coucher...
Michel

WWW

16 23-02-2021 00:16 -

Je viens de voir ta question, Michel. J'ai la même chose que toi  :  pour le serveur  utf8mb4_unicode_ci et pour les tables utf8_general_ci

WWW

17 23-02-2021 04:02 -

Je suis maintenant en version TNG 13.0.3. Je suis aussi passé à la version PHP 7.4 chez mon hébergeur. Je remarque que les nouvelles tables générées par une nouvelle installation ont le même jeu de caractères que vous (Michel et Katryne). Sur cette nouvelle version, je peux en effet chercher Francois et voir tous les François et vice versa. Donc, ce problème est réglé.

Là où j'avais vu le même comportement erroné était sur le site test de Katryne : https://tng-test.revestou.fr

18 23-02-2021 13:22 -

Michel, c'est toi qui répond et moi qui pose les questions, pas le contraire. Que j'en sais, moi ? Ya pourtant noté : utf8_general_ci pour les tables ...

WWW

19 23-02-2021 20:50 -

Bon ben alors : peux-tu vérifier avec PHPmyAdmin
l'interclassement de tes tables = UTF8-general_ci (normalement oui, tu l'as dit)
MAIS AUSSI les champs de chaque table (Structure d'une table, par exemple tng_cemeteries)

et aussi , fais voir un bout de chaine encodée dans ta base pour voir..

et enfin, que donne un SQL directement par phpMyAdmin (recherche avec/sans accents)?

Michel

WWW

20 23-02-2021 20:55 -

Ben là, ya : latin1_general_ci
C'est grave ?

WWW

21 23-02-2021 20:58 -

Je vois que je peux "modifier l'interclassement de toutes les tables" (case à cocher)
et
"Changer les interclassements de toutes les colonnes de toutes les tables" (autre case à cocher)
ça sert à quoi ces trucs-là ?

WWW

22 23-02-2021 21:16 -

Bon ben, d'après ce que je pense et ce que je lis,
les champs devraient être passés en utf8_general_ci aussi !

Donc, on fait un essai : Dans PHPMyAdmin :
tu copies la table tng_people (clic sur le nom de la table - onglet opérations -
dans le fond de la page tu trouves "copier la table vers...."
- tu change le nom proposé ("tng_people_copie" par exemple
- tu sélectionnes bien "Structure et données"
En bas à droite de cette partie, tu cliques "Exécuter" - Ta table est copiée (tu peux faire une seconde copie via TNG...)

Tu reviens à tng_people - onglet structure :

Champ lastname >> modifier >> interclassement changer en "utf8_general_ci" >> Enregistrer puis OK sur le message

Champ firstname : idem

Puis tu essayes à partir de TNG des recherches avec/sans accents/cédilles etc...

La suite si ça marche...

WWW

23 23-02-2021 22:05 -

Ca ne fonctionne certainement pas à cause des champs "date" = 0000-00-00 qui ne sont pas au bon format.
MAIS, tu es vernie : il y a un Mod !

https://tng.lythgoes.net/wiki/index.php … g_to_UTF-8

APRES avoir copié ta base de données complète (*), Installe le Mod, remplace utf8_swedish_ci en utf8_general_ci dans les paramètres, clique sur "Change database"

Teste... Si OK, tu peux désinstaller puis effacer le Mod et supprimer ta copie de base de données quand tu es certaine

(*) si tu sais pas, demande...

Michel

WWW

24 23-02-2021 23:10 -

Katryne a écrit:

Je vois que je peux "modifier l'interclassement de toutes les tables" (case à cocher)
et
"Changer les interclassements de toutes les colonnes de toutes les tables" (autre case à cocher)
ça sert à quoi ces trucs-là ?

Tu peux essayer. Coche les 2 cases. Ca devrait fonctionner aussi, sauf s'il n'apprécie pas les format de dates "0000-00-00".
Alors, utilise le Mod

Michel

WWW

25 24-02-2021 11:00 -

J'ai besoin de concentration pour ma lancer là-dedans, je verrai demain. Merci des conseils.

WWW